CANNY Lab Main window

From CANNY Wiki
Jump to: navigation, search

CannyLab user interface consists of a single window - the main program window.

Main window[edit]

The main window is divided into several areas:

  • window title;
  • main menu;
  • toolbar;
  • function block panel;
  • workspace;
  • status bar.

Depending on the current operating mode of the editor, some of CannyLab menu items and panels may not be available or hidden.

4 4 1.png

Main menu[edit]

Menu "File" contains commands for working with CannyLab files.

4 4 1 1.png  
- create a new function diagram file;
- open an existing function diagram file;
- save the current function diagram file;
- save the current function diagram file under a new name;
- save a screenshot of the function diagram in the PNG graphic format;
- view the current file properties;
- history of recently opened files (up to 5 records);
- Exit.


Menu "Edit" contains the basic editing commands for working with the function diagram editor.

4 4 1 2.png  
- undo the last action when working with the diagram;
- redo the last action when working with the diagram;
- cut the selected part of the diagram to the clipboard;
- copy the selected part of the diagram to the clipboard;
- paste a part of the diagram currently contained in the clipboard;
- delete the selected part of the diagram;
- search item by text;
- search next item by text;
- search previous item by text;
- search function block by its ordinal number;
- select of the entire diagram.


Menu "View" contains options for customizing the appearance of the toolbar, the function block panel, as well as an option for scaling the workspace.

4 4 1 13.png  
- scale the workspace by the contents of the diagram;
- toolbar appearance settings;
- function block panel appearance settings.
4 4 1 3.png 4 4 1 4.png


Menu "Device" contains commands for working with the controller.

4 4 1 5.png  
- search and establish communication with the controller connected via USB;
- actions for uploading and erasing the controller system software;
- actions for uploading and erasing the function diagram;
- information about the connected controller;
- space reserved for use in future versions;
- end the communication session with the controller;
4 4 1 6.png - upload firmware to the controller;
- erase controller firmware;
4 4 1 7.png - upload the user's function diagram to the controller;
- erase the user's function diagram from the controller.


Menu "Simulation" contains controls for the controller software emulation mode in the CannyLab environment.

4 4 1 8.png  
- enable/disable simulator mode;
- enable/disable focus lock on the active function block;
- enable/disable pause mode that activates upon detecting any changes to the data;
- start / pause / resume diagram execution;
- execute the active function block;
- execute the diagram up to the active block;
- stop and reset the simulator to its initial state;
- bind simulation time-scale to windows system time;
- set the format for displaying values in the simulator mode;
4 4 1 9.png - use the decimal number system;
- use the hexadecimal system;
- use the binary system;
- use character data mapping.


Menu "Service" contains service commands and CannyLab settings.

4 4 1 10.png  
- reorder function blocks numbers on the diagram;
- change the boundaries of the workspace by the contents of the diagram;'
- create a standalone firmware flash file;
- start CAN monitor;
- change CannyLab settings;
- change the interface language of CannyLab.


Menu "Help" provides links to this guide and information about the program.

4 4 1 11.png  
- view CannyLab version history;
- read END-USER LICENSE AGREEMENT file;
- open CannyLab reference guide;
- go to the online encyclopedia CANNY Wiki;
- check for CannyLab updates;
- get information about the current program version.

Toolbars[edit]

Toolbars allow access to the most used commands in CannyLab.

4 4 2 1.png

Desktop Control Panel allows scaling the area of the workspace and changing its dimensions in pixels. To quickly zoom in/out, rotate the mouse wheel while holding down the «Ctrl» button on your keyboard.

4 4 2 2.png   4 4 2 2a.png

Workspace[edit]

The workspace is designed to display, edit, and debug function diagrams. The background of the workspace is a grid that facilitates positioning of function diagram elements. To move around the diagram displayed in the workspace, use the vertical and horizontal scroll bars, mouse wheel or arrow keys.

4 4 3 1.png

Status bar[edit]

The status bar displays: the controller for which the current function diagram is designed, the status of communication with the controller, the presence of system software and function diagram in the connected controller. In the simulator mode the status bar displays information about controller resources used by the user diagram.

4 4 4 1.png

Function block panel[edit]

Function block panel contains all block types available for constructing the function diagram. Function blocks in this panel are grouped by their purpose and, depending on display setting, may be presented as either icons or a list. Scroll the function block panel by using the vertical scroll bar or your mouse wheel.

The two ways of displaying the function block panel:

4 4 5 1.png   4 4 5 2.png

Function block by ordinal number search dialog[edit]

Access the dialog for searching function blocks by their ordinal number by selecting "Edit" → "Find block" in the CannyLab main menu.

4 4 6 1.png

Text search dialog[edit]

Access the dialog that allows searching by the specified text fragment by choosing "Edit" → "Find..." in the main menu of the program or by using the "Ctrl + F" key combination.

4 4 6 2.png

If you’ve already used text search in the current session, you can continue searching for the currently entered text fragment by choosing "Edit" → "Find next"/pressing “F3” to find the next occurrence or by choosing "Edit" → "Find previous"/pressing “Shift+F3” to find the previous occurrence.

Settings dialog[edit]

Access the CannyLab configuration dialog by selecting "Tools" → "Settings" in main menu.

4 4 7 1.png

Checking for updates - Set how frequently the program checks for new software versions
4 4 7 2.png
Selected Net colour - Choose the colour of a selected connection line
Associate CFD file type with CannyLab - Associates function diagram file type with the current version of CannyLab
Default diagram width - The width of the diagram when creating a new file
Default diagram hight - The height of the diagram when creating a new file
Default diagram scale - The scale of diagram display area when creating a new file
Automatic selection of scale when opening a file - Enables fitting the diagram to screen automatically when opening an existing file.
Port to connect device - Choose a COM port for connecting devices that use the RS-232 interface for downloading the software (CANNY 5, CANNY 5 nano, CANNY 5.2, CANNY 5 duo, CANNY 5.2 duo)
4 4 7 3.png

Keyboard shortcuts[edit]

F1 Open Reference Manual;
Ctrl+N Create a new function diagram file;
Ctrl+O Open an existing diagram file;
Ctrl+S Save the function diagram file;
Ctrl+A Select all;
Ctrl+Z Undo the last action while working on the diagram;
Ctrl+Y Redo the last undone action while working on the diagram;
Del Delete selected diagram elements;
Esc Exit network editing mode;
Left, Up, Right, Down Shift workspace display area Left, Up, Right, Down;
PageUp, PageDown Shift workspace display area one page up, down;
Ctrl + mouse wheel Fast workspace zoom;
Alt + mouse wheel Horizontal scrolling within the workspace;
Shift + mouse wheel Fast vertical scrolling within the workspace;
Hold mouse wheel + move the mouse Move the diagram field within the workspace ("drag and drop").
Double-click the left mouse button In editor mode: on a network – open the rename network dialog; on a register – open the register editor dialog; on a constant – open the constant editor dialog with the last used option selected by default. In simulator mode: on a network – set/remove control point; on a function block – set/remove the breakpoint.
Ctrl + double-click the left mouse button In editor mode: on a constant – open the alternative constant editor dialog. In simulator mode: on a network – forcibly set the network value to "1"/remove the previously set value.